Viewing 10 posts - 1 through 10 (of 22 total)
  • Author
  • #2761

    I’ve been trying to configure ORP to work better with my ICS Pi 1X, and some settings I have to do to the file directly (like gain, etc)

    I’ve followed the instructions under custom svxlink that have been posted, to no avail.

    Do I need to build in the changes, or are the configurations already in the php file, and I just need to find and edit them?

    I did find the .php file that the svxlink.conf draws from, but I don’t see anywhere to make changes at.

    So far, using alsamixer, I’ve been able to adjust the gain and other items to where they work perfectly, but everytime I have to reset it or disconnect it when I’m working on something, the settings, of course, don’t keep.

    Can anyone help? I understand why the .php file needs to be edited…I just don’t know how to edit it and where to put the edits at

    Aaron, N3MBH
    Forum Administrator

    Hello Jack,
    I would assume you are referring to the knowledge base article “Custom SVXLink Configuration”. If so that is a bit out of date and needs to be rewritten/updated. The principles are the same, but in 2.0.0 things are in different locations than are mentioned in the KB article.

    For testing purposes, you can try stuff in the svxlink.conf file, but you need to be careful not to overwrite it while testing. But yes, items should be modified in the PHP that writes the configs. Since writing that article, much of this has been converted into PHP classes. Most of what you are looking for should be in the “/var/www/openrepeater/includes/classes/SVXLink.php” file. These files only have what is being used, so you’d need to add in extra svxlink variable if required or find the ones you wish to change. This class is formatted a little different than previously. It builds a multi-dimensional associative PHP array…which later gets parsed into the INI format that SVXLink expects. You can still find the relative sections and the key/value pairs, but you just need to format as a PHP array.

    The upcoming version of ORP will be adding a backup/restore feature, which will backup and restore the alsamixer settings.

    Aaron – N3MBH / WRFV871

    OpenRepeater is offered free of charge. Find out how you can support us.

    • This reply was modified 5 years, 2 months ago by Aaron, N3MBH.

    Hello:I tried /var/wwww/openrepeater/includes/classes/SVXLink.php and it appears the file is empty, no there lines of code? I want my changes to the SVXLink config file to not be overwritten by the rebuild command from ORP but retain ORP for monitoring the system. Where do I need to go?


    If you remove one W from the part of the command between /var/ and /openrepeater, that will get you in. I had to do the same and it works fine.


    Thanks for the tip. I wondered about the four W’s instead of three. What line did you change to keep the REBUILD command from overwriting your changes to the config file. I want to use the simplex configuration for echolink. Tried to reverse the repeater and simplex files at the bottom but did not work.

    ADDED: I changed the section for “repeater” to “simplex” to make it identical to the simplex section below and that worked so when rebooted from dashboard it rebuilds to a simplexlogic configuration, which is all I need for my echolink node using the ICS-1X controller. A clumsy bit of code, but it works.

    • This reply was modified 5 years, 3 months ago by Randy, N4UUJ.

    Sorry I’ve been out of pocket.

    If you make the changes to the .php file mentioned above, the changes should stay in effect. The .conf file draws its information from that file in particular. So, make the changes, write them out (ctrl-o), and then exit.

    I usually then go into the GUI open in a browser and make a change so you get the option to rebuild and restart. Thus far, its been flawless and all changes made have stayed as I needed them.


    The rebuild and restart command seems to hang up and the banner stays on the top of the GUI so I have to reboot, which works, but my change to simplex has effected more than the mode. Have not noticed anything else, so far, however. Changes to GUI do take place, but not as smoothly as before. Had to adjust timings to avoid ping pong of repeater I am linking to and have noticed that the first letter of my call is being missed so will investigate a delay setting. I see many settings that could be adjusted, but I hesitate to change a working version since I do not know what each setting effects. Are there some common useful settings I should look at or is it best to leave them alone.

    Aaron, N3MBH
    Forum Administrator

    Am I correct in guessing that you are using version 2.0.0? I am unclear what you are changing as far as “repeater” to “simplex”. Are you trying to do this within the “/var/www/openrepeater/includes/classes/SVXLink.php” file? If so I don’t think you will get the results that you desire. The logic there is looking towards a database. If programming is not your thing, but you have reasonable command line experience, then you may be better off building a 2.1.0 image using the build script on a fresh install of Raspbian Lite. 2.1.0 is not officially released as of this posting, but it should be coming soon. We were working on debugging things.

    2.1.0 has a simplex mode in the GUI which you can enable along with the echolink module to create a simplex node. I would recommend keeping what you have and start with a fresh SD card. Or if you can hang in there, wait for the 2.1.0 release.

    Aaron – N3MBH / WRFV871

    OpenRepeater is offered free of charge. Find out how you can support us.


    Hello Aaron, Version 2.1.1 works good in simplex mode to use as an echolink simplex link to our local repeater (thank you), except I once again have the “ping pong” when the repeater drops…the simplex link answers back with a beep which keys the repeater again, etc.
    I had solved the problem by increasing the SQL_Start_Delay from 1 to 1000 in my old modified version but that does not seem to have any effect with the new 2.1.1. I tried 1200 with no change. Tried the old version and all OK, so nothing else has changed with the repeater. I have checked all the values and lines and they appear the same as my old program (svxlink.conf) but does not work the same. Any ideas of what to try. I have no short or long id’s and no courtesy tone, as requested by the repeater owner. Using COS with Yeasu FT1500 data DIN input and ICS 1X controller. Open_ON_SQL=1 and OPEN_SQL_FLANK=OPEN.
    Randy N4UUJ

    Aaron, N3MBH
    Forum Administrator

    I am trying to get a better understanding of what you mean by ping ponging…or what exactly is happening. You mentioned a beep. I am trying to remember if this is a beep issued by echolink/module. Would need to try and recreate your setup. Can you send me an .orp file if I email you directly?

    Aaron – N3MBH / WRFV871

    OpenRepeater is offered free of charge. Find out how you can support us.

Viewing 10 posts - 1 through 10 (of 22 total)
  • You must be logged in to reply to this topic.