Setting language

Home Forums General Discussion Setting language

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #3244

    Hi,

    I’m new here and must translate with Google. I have a problem:
    I have a problem with the language setting. Unfortunately I am not able to change the setting in “svxlink.conf” from – en_US to de_DE. Does anyone know how to set that permanently?

    regards
    René DL4BBD Sysop: DB0EWB

    #3245
    Aaron, N3MBH
    Forum Administrator

    Hello René,
    I will already assume that you have the SVXLink language files for de_DE. While we don’t have multilingual features build into yet…it is on the todo list. For now, en_US is hard coded into the PHP that writes the config files. There are 2 ways around this:

    First and the easiest – simply rename the default en_US to something else like en_US_ORIG. Then rename de_DE to en_US.

    The other option is to each the PHP. You can find this at /var/www/openrepeater/includes/classes/SVXLink.php
    Just search for en_US and replace with de_DE. It should appear in the file twice. After you initiate a change and rebuild the config this should work.

    I don’t know what the differences are between German and English, but if things are not fully the way you’d expect them you may need to modify the local.tcl file. I think there should be pointers out there on how to do this for German. ORP does not overwrite this file.

    73,
    Aaron – N3MBH

    OpenRepeater is offered free of charge. Find out how you can support us.

    #3246

    Hello Aaron,

    This is a good idea with renaming the code file. Example: The clock announcement is announced in DL every 24 hours. 73 René

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.