New User problem system oscillates using GPIO control

Home Forums Getting Started (Software) New User problem system oscillates using GPIO control

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #3515

    Hi I need some help as I have been fighting this problem for some time. I think
    I have tried all the setup configurations to try to stop the oscillation to no avail. I am using a Pi 4 B and have set OPR per the procedure on the websige.
    I am using GPIO pins 27 and 23 to control COS and PTT respectively. In my
    estimation once the signon message finishes the only time the PTT GPIO pin
    should go true is when you are transmitting from your phone or a computer. With
    the exception of the Echolink ID. But my configuration has a 250 ms PTT true
    every time the COS line goes true and finishes. That is with 0 sec squelch
    delay. The PTT stays true longer as you increase the Squelch delay making the
    oscillation slower. My OPR version is 2.1.3. I am willing to hack the Config
    files to fix this problem and not reload by using the dashboard if a fix is
    not going to happen soon!
    Mike in Texas

    #3516
    Dan, KG7PAR
    Forum Administrator

    What hardware board are you using, or what is the schematic of the interface adapters you are using to convert radio signals to those compatible with the RPI?

    The port 1 is a repeater, so yes it is expected that the COS would trigger the PTT to immediately go active and would stay active until the COS is released plus some small delay.

    Additionally the PTT will go active when the system self identifies, and when there is an incoming echolink event.

    There is nothing unstable in the default settings, this revision has been available for several years now with no reports I am aware of related to instability. Perhaps the TX radio is getting into the RX radio? I have seen this several times and will appear to be an oscillation behavior as the TX causes the RX to open which causes the TX to enable, cycle repeats indefinetely

    #3517

    Sorry I forgot to tell you that I am using a simplex mode. So the answer above is not relevant. I
    have removed the PTT gpio 27 from the Pi and monitored GPIO pin 27 with a scope and am see that it
    goes true for the short 250 ms time when the transmit button on the phone or computer is not active
    or any other signals present on echolink. The 250 ms true signal is present when OPR squelch tail
    setting is set to zero otherwise the signal is there for 250ms plus the squelch tail setting. The
    squelch tail setting just makes the oscillation slower. I will include the schematic that I am using
    I hope you don’t get confused if you don’t know how the Baoefeng Radio works.

    I hear the audio in both directions just fine but that hi true on GPIO 27 makes the system oscillate.
    K5OQ-R is the echolink ID.

    I don’t see how to upload a file here so I have sent you and email dloranger08@gmail.com with the
    file attached.
    Mike
    ad5su

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.