Mutting audio files

Home Forums General Discussion Mutting audio files

This topic contains 5 replies, has 2 voices, and was last updated by  Dan Loranger 2 months, 1 week ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #2732

    Hi,
    How and where can i mute audio spelling of ID Repeater, when repeter is sterted?
    All other commands i muted in /usr/share/svxlink/events.d by putting changed files in local directory, but spelling command is in ORP_RepeaterLogic_Port1.tcl. This file is overwritten by ORP module. How to mute this?
    Tom SQ4BJA

    #2733

    Temporary i make new file local/ORP_RepeaterLogic_Port1.tcl with muted procedures. Now it works, but how to make it permanenty?
    SVXLink is so talkative. Normaly users can`t stand it. So most of voices should be mutted. please, think about mutting option in ORP.

    Tom SQ4BJA

    #2734

    Dan Loranger
    Forum Moderator

    Hi Tom,

    I am not at a station at the moment, but in the ident tab at the bottom you should be able to change the ID from CW to voice or both. I found a bug in the current development that may have been lingering so try that first and if it doesn’t work assume this is the same bug which has been fixed already in the development code.

    assuming you hit the bug, you need to create a overrides file for the logics, this is actually the prescribed way of svxlink for doing custom idents.

    read here to learn the prescribed way to override the idents behaviors. This is a useful thing to know about in general
    https://github.com/sm0svx/svxlink/wiki/InstallationInstructions
    in “The Event Handling Subsystem”

    #2735

    Ok, thank You.
    And please tell me, how to change GPIO PTT and COS to ttyS0 RTS DTR?
    Tom SQ4BJA

    #2736

    Dan Loranger
    Forum Moderator

    Hi Tom,

    Reading more closely you are already using the overrides so that is a good start.

    Maybe I misunderstood your question now with a 3rd read. I normally don’t hear the ident when svxlink stock first boots up, I typically customize my install to announce that it is “online” so I know it is running sucessfully. I do notice that the system likes to ident on the first transmission over the top of the person keying the mic. Is this what you are talking about?

    There is also this setting that might help lower down the chatter level, I need to do this on my system as well.

    https://github.com/OpenRepeater/openrepeater/issues/58

    #2737

    Dan Loranger
    Forum Moderator

    I don’t have any experience with using the ttyS0 ports, but I do know it is supported as I have seen it in the “manual” as excerpted below for the PTT portion

    http://www.svxlink.org/doc/man/man5/svxlink.conf.5.html#STATE%20PTY%20FORMAT

    PTT_TYPE

    Use this configuration variable to specify which type of hardware to use to control the PTT. Specify “SerialPin” for using a pin in the serial port, “GPIO” to use a pin in a GPIO port, “PTY” if you want to use an external interface script via a pseudo tty port or “Hidraw” to use the linux/hidraw driver to support hidraw devices like CM108 sound card, e.g. URI device from DMK.

    Set PTT_TYPE to “Dummy” or “NONE” to not use any PTT hardware at all. It is an error to not specify PTT_TYPE.

    Use PTT_PIN to specify the pin to use for “SerialPin” or “GPIO”.

    PTT_PORT

    Specify the serial port that the PTT is connected to. E.g. /dev/ttyS0 for COM1.

    PTT_PIN

    If PTT_TYPE is set to “SerialPin”, specify the pin(s) in the serial port that the PTT is connected to. It is possible to specify one or two serial port pins. Some interface boards require that you specify two pins since one pin does not provide enough drive power to the circuit. A “!” in front of the pin name indicates inverted operation. Some of the possible values are RTS, DTRRTS, !DTR!RTS or even DTR!RTS.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.