Echolink Port Forwarding

Home Forums Getting Started (Software) Echolink Port Forwarding

This topic contains 3 replies, has 3 voices, and was last updated by  Aaron, N3MBH 2 months, 2 weeks ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #2703

    Is there a way to test the router/firewall from the ORP itself. My status show as being up, I can can connect to the test server and hear echo back but cannot connect to my ORP repeater. My ISP has opened the ports on the DSL router so my laptop connects to other nodes but not mine. Have tried thru cell network so not on my wifi router. Times out. The “router test” failed until ports were opened but have not way to prove ports are open for the ethernet connection to to router from ORP. Same ports have been opened for the ORP but no connection. Is there a better method other than trial and error?

    #2705

    Aaron, N3MBH
    Forum Administrator

    Hello Randy,
    The first step is to ensure that your pi has a static IP address on the network. You don’t want your ip address changing randomly otherwise port forwarding will not work. For me, I have a more advanced router that allows me to map a static IP address to my devices based on their network adapters MAC address. I find this the easiest way to assign a static. If your router doesn’t have that feature then you will need to manually configure it. In previous versions of Debian/Raspbian this used to be done in “/etc/network/interfaces” but I pretty sure that has changed in Stretch, but I have not familiarized myself with how to configure that. We have a KB article on this, but it needs to be updated to work with Stretch.

    Once you have a static set, then you can concentrate on port forwarding. Note that the main ports you need to worry about (5198 and 5199) are incoming so you won’t be able to test internally. You can probably use an external or web based port scanning tool and scan your WAN IP of your router provided by your ISP.

    EchoLink requires that your router or firewall allow inbound and outbound UDP to ports 5198 and 5199, and outbound TCP to port 5200. Note the most routers will just open up the requested outbound port (5200 upon request). It is just the inbound ports that you need to configure. You will need to configure the router to “forward” UDP ports 5198 and 5199 to the IP address assigned to your OpenRepeater controller. Note I say forward as opposed to just opening the ports. It needs to know where to send the incoming traffic once it comes in. So Both ports 5198 and 5199 will need to forward to the internal IP address of your ORP controller. They also need to be configured as UDP ports and not TCP ports.

    Echolink has some good information here: http://www.echolink.org/firewall-friendly.htm Not all of it will apply to EchoLink on ORP/SVXLink, but much is the same. They mention a site called https://portforward.com that might be able to help you with the specifics of your DSL Router.

    73,
    Aaron – N3MBH

    OpenRepeater is offered free of charge. Find out how you can support us.

    #2713

    Hi Randy,

    I have a similar problem. Parrot works through the test server, but I have not found a way to test incoming voice through the internet.

    I noticed that echolink seems to allow only one callsign type at a time.
    When attempting to connect to my WB6YAZ-R node from the android app, the WB6YAZ (non-sysop) is disabled and cannot connect to any node.

    If you need someone to test your incoming data, list your node# and I will attempt to connect.

    My node# is: 223532 (WB6YAZ-R, FN20xd)

    -Gregg (WB6YAZ)

    #2716

    Aaron, N3MBH
    Forum Administrator

    Gregg,
    Yes that is correct and something I didn’t really think to include above.

    Randy,
    If you are testings connecting to your own station…say using the EchoLink iPhone app to connect to your OpenRepeater…then yes you do need to have separate node IDs registered with EchoLink. So in my case I used N3MBH on my phone and N3MBH-R on my OpenRepeater. Not sure if that would be your problem or not, but it is certainly work mentioning.

    73,
    Aaron – N3MBH

    OpenRepeater is offered free of charge. Find out how you can support us.

    • This reply was modified 2 months, 2 weeks ago by  Aaron, N3MBH.
Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.