Adjust input and output audio

Home Forums Getting Started (Software) Adjust input and output audio

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #2700

    I’m New with open repeater software all work but I like to adjust input and output audio lever with à software the audio is a bit to high how is the possibility to adjust.

    MARIO

    #2701
    Dan, KG7PAR
    Forum Moderator

    Mario,

    You can use the soft audio adjustments through the SSH interface. Once you login via ssh, you can open the alsamixer utility to adjust the audio, but the adjustment levels are usually very rough (20%) so you are better off using a potentiometer in the audio path for fine adjustments on both the input and output audio.

    #2718

    when I try to open alsamixer I get:
    root@orp:~# alsamixer
    cannot open mixer: No such file or directory

    #2719
    Dan, KG7PAR
    Forum Moderator

    Are you using a distributed image of orp or a self built one? If a distributed image, a reimage may help to resolve your issue as well if the below doesn’t work.

    It should be there by default, but you could try running

    apt-get install alsa-utils

    To reinstall the utility.

    #2722
    Aaron, N3MBH
    Forum Administrator

    N0FON,
    First make sure that alsamixer is recongnized:
    which alsamixer
    Should give you a response with a path to alsamixer. If you get nothing in response then it is not installed.

    Secondly, I have seen before where the sound device doesn’t get assigned the anticipated card number and alsa mixer can’t find it?

    What is the output of:
    aplay -l

    Depending on the card number returned you may need to use a switch after alsamixer to select the card. What exactly that is I cannot say at the moment, as I’m not at my home office at the moment.

    73,
    Aaron – N3MBH

    OpenRepeater is offered free of charge. Find out how you can support us.

    #3237
    Milan
    User

    this tread is rather old, but still, i have a similar problem.
    in the alsamixer (i have to use the command “alsamixer -c 1”
    i have only output controlls,
    under capture it says “this sound device does not have any capture controls.”

    the issue im havving:
    RX audio is fine,
    TX audio is fine, (since i boosted the output to -3db)
    RX audio for Echolink is fine,
    TX audio for Echolink is super quiet! (like 25 to 30 db’s )

    is there a way to set echolink audio independently?

    also, the sound is a bit dull, so i would like to add an Equalizer
    i try the alsamixer equalizer, it installs. but does nothing..
    (at first, only the output EQ should do for now 🙂 )

    i hope someone is still active here hi

    kind regards, 73.
    Milan Hofman PD0HOF(-R)

    #3238
    Aaron, N3MBH
    Forum Administrator

    Hello Milan,
    What hardware are you using for your audio interface? If you are saying that your audio is dull, there could be a number of things to look at. The SVXLink core supports pre-emphasis and de-emphasis in software, but ORP currently sets this at a fixed setting (No UI control). Some interfaces like the ICS Controllers interfaces have hardware selectable pre-emphasis and de-emphasis. It may also depend on how you are interfacing with your radio as well or settings withing the radio. I know for instances on the old Motorolas you have different audio pins for flat vs modified audio and there are also some settings in the Motorola CPS software. So there are a couple places where things can get messed up.

    As for the EchoLink. The SVXLink module offers no settings for adjusting the audio levels. You may be best to use Echolink as your standard and adjust your repeater input audio to match that. Then it should output at around the same level. You may also want to make sure that you are using multiple EchoLink sources to confirm your claim. I would also use that source and try connecting to the Echolink test server (9999) to see how the replayed audio compares with the level of the prompts. Getting everything setup correctly can be a fine balancing act since there are a number of controls in the audio path that can affect one another.

    73,
    Aaron – N3MBH

    OpenRepeater is offered free of charge. Find out how you can support us.

    #3239
    Milan
    User

    for the audio interface im using a Behringer UCA222 (since i had it on hand)

    for repeater im using a TXU1256 by tripple P
    witch only has flat audio in and outputs.

    about the echolink problem, its sad to hear there is no gain setting for echolink.
    RX audio is perfect, no audio hiss nice and hot but not over driven. ofcorse i can put a attenuator on the input but than i have to build an amp stage asswel to makeup for the attenuator (since the soundcard is maxed allready)

    i just set de-emphasis off and that “fixt” it
    its sounds kind of harsh right now,. but maybe im used to the muffeld dull sound now hihi

    thanks for the fast respons 🙂
    73,
    PD0HOF

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.